Thursday, October 25, 2012
How to extend / root filesystem in hp-ux 11.31.
#How to extend / root filesystem in hp-ux 11.31.
#get a space disk.
#Add a disk
ioscan -fnC disk
vgdisplay -v vg00
/usr/sbin/diskinfo /dev/rdsk/c0t8d0
insf -Cdisk
#add spare disk to vg00
ioscan -fnC disk
pvcreate /dev/rdsk/c0t8d0
vgextend vg00 /dev/dsk/c0t8d0
vgdisplay -v vg00
#unmirror vg00
lvreduce -m 0 -A n /dev/vg00/lvol4
lvreduce -m 0 -A n /dev/vg00/lvol5
lvreduce -m 0 -A n /dev/vg00/lvol6
#Move to spare disks.
pvmove -n /dev/vg00/lvol4 /dev/disk/disk7_p2 /dev/dsk/c0t8d0
pvmove -n /dev/vg00/lvol5 /dev/disk/disk7_p2 /dev/dsk/c0t8d0
pvmove -n /dev/vg00/lvol6 /dev/disk/disk7_p2 /dev/dsk/c0t8d0
#Extend root lv
lvextend -L 10000M /dev/vg00/lvol3
fsadm -F vxfs -b 10000M /
#Move back.
pvmove -n /dev/vg00/lvol6 /dev/dsk/c0t8d0 /dev/disk/disk7_p2
pvmove -n /dev/vg00/lvol5 /dev/dsk/c0t8d0 /dev/disk/disk7_p2
pvmove -n /dev/vg00/lvol4 /dev/dsk/c0t8d0 /dev/disk/disk7_p2
#remove the space disk
vgreduce vg00 /dev/dsk/c0t0d0
pvremove /dev/rdsk/c0t8d0
rmsf -H 0/0/0/1/0/0/0.8.0
ioscan -funC disk
#mirror vg00
lvextend -m 1 /dev/vg00/lvol4
lvextend -m 1 /dev/vg00/lvol5
lvextend -m 1 /dev/vg00/lvol6
Labels:
extend,
HP-UX,
root filesystem
Subscribe to:
Post Comments (Atom)
No comments:
Post a Comment